"Auto chords" are interrupted

11 posts / 0 new
Last post
tom11's picture
tom11
Offline
Last seen 4 months 1 week ago

"Auto chords" are interrupted

The auto chords are interrupted/stop sounding in the moment when a figure in a second container on another instrument starts playing.

This is only with auto chords/auto bass. If I span a chord over 4 bars manually then it does not stop.

Reproduce this issue (see also screenshot):

Add two instruments of different modules/sounds, for the first instument some strings (or other sustaining sound) and the second some other, eg. piano.

Add two containers. The first starts at bar 1 and contains the auto chords on the string instrument .

The second container starts at   bar1 +1/2 and contains some figure on instrument 2.

The string chord sound will stop at bar1 +1/2.

 

Attachments: 
andre's picture
andre
Offline
Last seen 1 day 13 hours ago

Auto-Chords and Auto-Bass are settings of the Interpretation parameter that override any Figure that might also be present. If a new container contains an Interpretation parameter with different settings, the auto-generated notes will stop.

You probably have an empty phrase in that second container that still has Interpretation populated.

(We are looking to move these generative features to a new parameter that is independent of Interpretation)

tom11's picture
tom11
Offline
Last seen 4 months 1 week ago

You probably have an empty phrase in that second container that still has Interpretation populated.

No, the steps above are complete. There is only one interpretation parameter set in the whole arrangement: in the first container (Auto chords), and for the strings only.

So this clearly looks like a bug...

 

Attachments: 
andre's picture
andre
Offline
Last seen 1 day 13 hours ago

Such an obvious bug would be noticed immediately in almost every arrangement. I tested your scenario here and it works as intended. 

There must me some parameter that overrides or disabled the auto-chords in the nested container. Check all parameters.

andre's picture
andre
Offline
Last seen 1 day 13 hours ago

Aaah, ok: You don't have Harmony assigned. Of course, you need a chord progression in order to render music. That default single C chord is only triggered once.

tom11's picture
tom11
Offline
Last seen 4 months 1 week ago

Now I have also harmony assigned! I have also removed the second instrument. The container B is complete empty, just created from menu "Container - New container".  See my screenshot.

So again, to reproduce this issue, here are the complete steps:

- Create a new arrangement

- Assign some sustained instrument to the (one and only) "no sound" labeled instrument

- Create a container A at offset  0m below the root container. Create a harmony, ie. a chord C, spanned over one bar or longer.

- Assign interpretation "Auto Chords" to the (one and only) instrument

- Create a new container B at offset  0m+2/4 below the root container. Do not do anything with this container.

- Start playback: The sound will stop at pos  0m+2/4.

- Remove the empty container B. Start playback: The sound will not stop until pos  5m (in my example)

 

And yes, this issue occurs in almost every of my arrangements at some point.frown

But now I could strip it down to the most simplest arrangement that reveals this issue.

(Of course, if I create a chord C at the beginning of container B (ie. override the harmony of A), then the sound is triggered again. But I want it to be sustained over one bar without being retriggerd.)

Attachments: 
janamdo's picture
janamdo
Online
Last seen 1 hour 4 min ago

How could a empty container do something ? smiley
In both cases it seems to be working the autochord feature

- from bar 1 to 5 : the chords are placed in a container
- from bar 9 to 12 the chords are in the rootcontainer
 

I added also the autobass + autochords together playing

andre's picture
andre
Offline
Last seen 1 day 13 hours ago

@tom11

A container switch prevents an already playing auto-chord to sustain across container bounds, if container bounds are not aligned with the rhythm of the chord changes. This is indeed not intuitive. I'd say you're right, it's a bug.

It's interesting how nobody yet noticed this. Probably because for musical styles that tend to make use of auto-chords, containers are usually aligned with the rhythm of the progression (dance, electronic, pop/rock, hiphop). And musical styles with a high probability of odd container placements would never use auto-chords (jazz, orchestral, piano).

Auto-chords is really only a crutch to get a quick draft or preview of a progression. We will be separating these generative features from the Interpretation parameter anyway. There will most likely be a new parameter for this with more intuitive controls and its own user interface.

tom11's picture
tom11
Offline
Last seen 4 months 1 week ago

I'm using the auto chords for many "pad" like sounds. I actually prefered it over manually drawing chord figures because it reliably triggers a chord at every new (harmony) chord AND sustains. Is there a another way how this could be achieved ? (enabling long sustained sounds but if the chord is only 1/4  then react on that change and re-trigger it?

janamdo's picture
janamdo
Online
Last seen 1 hour 4 min ago

Drop the harmony parameter from the progression on the figure parameter slot of the instrumenttrack, then Synfire draw the chords 
 

blacksun's picture
blacksun
Offline
Last seen 1 day 22 hours ago

check out the options on the interpretation parameter. It gives you a lot of control over how the harmony affects the chords on your instrument 'track'. Assuming the notes are long enough, you can have them continue to sound, ignoring change of harmony; synfire look ahead in time and make them change early or just change with the harmony change, and other options too I cant remember.

Log in or register to post comments

Scholarly Lite is a free theme, contributed to the Drupal Community by More than Themes.