how do i turn off program change commands?

5 posts / 0 new
Last post
zcor's picture
zcor
Offline
Last seen 14 years 11 months ago

how do i turn off program change commands?

i'm using the navigator demo hooked up to my daw (with midi yoke) and whenever i'm recording a midi clip using it as a controller it keeps changing the program on the softsynth i'm using back to number 1... i'm guessing this is an easy one to solve...

i'm seriously considering buying the full version but first i'd like to see if it will work as i expect it to.

andre's picture
andre
Offline
Last seen 11 hours 11 min ago

Hi,

you should add (create) a new device under "Audio & MIDI Setup" that uses fixed midi channels and no program changes (or whatever your DAW sound generator/virtual instrument requires to be controlled). Add a new bank and then add a sound for each sound you want to play on the DAW's software instrument and

- if a program change is required to select the sound, specify it
- if the sound is always playable on a particular midi channel, use it
- if the sound resembles some natural instrument, drag it onto the appropriate instrument category as listed in the tree view

It would probably best to disable the default GM software synth, as all preset accompaniment patterns use GM sounds by default.

HTH

Andre

P.S: IIRC, the demo only provides 1 MIDI port (16 channels). The full version has 8.

zcor's picture
zcor
Offline
Last seen 14 years 11 months ago

hi andre, and thank you.

i tried your solution and it seems to work, however i am noticing something strange :

i've been trying HN as midi-through or as MIDI input to control an instance of z3ta+ on my sequencer, and occasionaly when i do this the volume slider on the vst will go down to say 20%.

i have noticed that there are a number of sliders in the audio/midi setup of HN that allow control over the receiving vsts volume, however none of them is at 20%, all of them are at acceptable levels (like 70%).

any idea on what is going on here?

andre's picture
andre
Offline
Last seen 11 hours 11 min ago

There are two places to define volume:

1) The default volume of the sound, as set with the device that defines the sound (or on the tab "Standard Instruments, Preferences" when used as a global default sound)

2) The volume parameter as set in the accompaniment pattern

It looks the pattern you are using specifies a low volume for the instrument that uses the sound. You should check this. You could also delete the parameter and HN will then use the default volume of the sound.

HTH

Andre

breeze's picture
breeze
Offline
Last seen 13 years 10 months ago

@zcor:

you did not write which DAW you use. In my case (Logic Pro), a volume value of 127 refers to a +6dB in the mixer, whjch is not what I want. 0dB refers to 90. Therefore I set my instruments to 90 as the default value. Furthermore I used a filter on the DAW side to filter out all program changes and volume changes, so that my mixing is all done on the DAW side, and HN just sends the notes. Maybe you can do something similar with your DAW?

Regards,
breeze

Imac Intel 2'16, Mac OSX 10.5.1, Logic Pro7

Log in or register to post comments

Scholarly Lite is a free theme, contributed to the Drupal Community by More than Themes.