"Device is not connected" - Why ?

6 posts / 0 new
Letzter Beitrag
Bild des Benutzers tom11
tom11
Offline
Last seen vor 3 Monate 1 Woche

"Device is not connected" - Why ?

I just started with the latest synfire on a new machine and try to build up the globalrack (64bit only).

I added 2 Rack modules (Sylenth1), choose 2 different sounds (presets) on each one, but when I try to use them in an arrangement, synfiere complains "Device is not connected", though the rack seems to be set up correctly. What's wrong ?  If I click on "Probe" in the global rack, it plays both sylenth1 sounds correctly

 

Attachments: 
Bild des Benutzers petearch
petearch
Offline
Last seen vor 6 Stunden 27 Minuten

The information displayed in red relates to the track you've got selected in your arrangement. Unfortunately we can't see what it is, as it's hidden by your global rack but I suspect it's a piano? So Synfire is asking you if you want to accept the Sy Rhodes Electric Piano because you haven't got a piano category assigned in the rack module that you've circled.

Pete

Bild des Benutzers tom11
tom11
Offline
Last seen vor 3 Monate 1 Woche

I haven't assigned piano category because it's not a piano sound, it a synth bass category. After setting up the rack, I added a new instrument in the arrangement and chose the sound previously added to the global rack: DR sidekick.  It is available from the global sounds drop down menu and when selected for the new instrument, it shows the error "not connected".   No idea what's wrong with it.

Bild des Benutzers andre
andre
Offline
Last seen vor 4 Tage 22 Stunden

This is difficult to diagnose from remote. The message indicates the device description referred to by the sound assignment is not selected on any rack module. Do you have multiple device descriptions with that same name? Maybe one is connected and the other is not?

Usually it helps to pick the sound from the sound browser again. The browser would not list sounds that are not connected.

Bild des Benutzers tom11
tom11
Offline
Last seen vor 3 Monate 1 Woche

I  already selected it again, restarted Synfire, it is always in the drop down list and when assigned to an instrument the error appears.

It seems the sound/preset is resetted to Bank 0 Prg 0: Actually I chose a preset from bank 3 : Prg 43 (Synfire automatically set Lsb to 3).

Sylenth is a VST  (updated in 2017) with 4 banks with each 128 presets. The presets and banks are extracted by Synfire. I select bank 3 and a program and set a category for it. Synfire sets "dynamic "for channel.

It would be easier if one could just select the preset in the plugin editor and tell Synfire: Use the plugin as configured, don't send any bank or program changes.

Is this possible ?

 

 

 

 

 

Bild des Benutzers andre
andre
Offline
Last seen vor 4 Tage 22 Stunden

Yes this is possible. 

Simply setup the instrument as a fixed-channel (sampler) device that has no programs or banks. Just like you would setup a NI Kontakt sounds, for example. The Sound Selection Wizard should be fine for that task.

Zum Verfassen von Kommentaren bitte Anmelden oder Registrieren.

Scholarly Lite is a free theme, contributed to the Drupal Community by More than Themes.