Direkt zum Inhalt

Snippets play choppy



Maybe not a bug but more like performance issue - playing Snippets is choppy, even with not so many snippets added (<20). 

The live rack is shown without any controls too (see attachment).



Synfire Pro 2.3.4 Build #2

OS    Windows 11 Pro N
Version    21H2
Installed on    ‎17. ‎12. ‎2022
OS build    22000.2538
Experience    Windows Feature Experience Pack 1000.22001.1000.0

Processor    Intel(R) Core(TM) i7-6700 CPU @ 3.40GHz   3.40 GHz
Installed RAM    32,0 GB (31,9 GB usable)



Di., 24.10.2023 - 16:31 Permalink

Only Figures and Harmony. The figures were recognized from midi files with import settings as on image:

Midi import

Di., 24.10.2023 - 16:50 Permalink

That should be fine. Please check if there is excessive controller data in the snippets. That could be an issue.

Di., 24.10.2023 - 16:53 Permalink

Oh, and if the figures are like 100m long, that could also be an issue. They should not be much longer than the snippet container.

Check out this tutorial how to import MIDI filed and slice them into reusable phrases.

EDIT: I see you used automatic creation of phrase pools at around 2m. That should not give you any extremely long figures.

Di., 24.10.2023 - 19:42 Permalink

Using Figures from example libraries improved the performance. Seems that they are stripped of any midi controller events. Nevertheless, during about 50% Play(s) of snippets (equivalent in content) the slow-down occurred regularly at the beginning of each bar. So I assume the playback is still hitting the limits. I will observe it further. If there is possibility to turn on some performance logging I can do it too and send you the log.

Di., 24.10.2023 - 20:48 Permalink

There's currently a bug when negative locators are disabled (Audio Engine should ignore that). 

Check the timing settings on the parameter inspector and enable negative time. That should improve playback behavior with the Audio Engine.

Fr., 02.02.2024 - 20:39 Permalink

Hi Andre,

Just updated observation - the choppy playback is increasing the more movement of mouse cursor is performed over snippets (of course, for stop/start of different snippet, some cursor movement is required) If it started it remains choppy even after stopping cursor movements. The only way to "reset" it is to stop and start playback. Let me know if this helped the investigation as the issue still occurs even on newest version 2.4.2 Build #3 (Windows)