Setup Akai EWI USB Control With a DAW

7 posts / 0 new
Last post
supertonic's picture
supertonic
Offline
Last seen 11 months 13 hours ago

Setup Akai EWI USB Control With a DAW

Some users asked for it. Here are the instructions how to use EWI Control with your DAW:

 

 

Akai EWI USB Control can be chained between the EWI-USB hardware and your DAW. For this you need a MIDI Loopback Driver ("virtual midi cable"):

    EWI-USB => Akai EWI USB Control => Loopback Driver  => DAW

On The Mac, a Loopback Driver is part of the system. Spotlight for "Audio MIDI Setup" and open its MIDI Window. There you find the IAC Driver. Make sure it is online and has at least one port created. The loopback ports should now appear as "IAC Bus" in the list of available MIDI ports on your Mac.

On Windows, you will need to get a third party loopback driver (LoopBe, MIDI Yoke, or similar). We have tested with LoopBe (www.nerds.de).

After setting up a loopback port, restart your DAW and the Akai EWI USB Control utility. In the utility, select "EWI-USB" for midi input and "IAC Bus 1" as output. In your DAW, select "IAC Bus 1" for midi input. Now the midi signal flows from your EWI-USB to the utility and then to your DAW input as shown in the diagram above (replace "IAC Bus 1" with the respective loopback port names on Windows, e.g. "1. Internal Midi").

 

spartacus's picture
spartacus
Offline
Last seen 1 month 1 week ago

hello

i just buy the Akai Advance 61 , it is possible to have a mapping Synfire Pro? For control Synfire like all other DAW inside the controler keyboard

thanks

I BE BACK!!

marco56's picture
marco56
Offline
Last seen 2 months 3 weeks ago
Hello everyone. I can't get any sound from my Akai Ewi Usb connected to Logic Prox with the Akai Ewi Usb Cognitone controller. I followed the guide and playing Akai in Logic the leds are active but no sound comes out. However, I see that by choosing external midi in Logic, "IAC Bus 1" is selectable only as Output and not as Input as specified in the guide. What could be the problem? Thanks a lot!
andre's picture
andre
Offline
Last seen 15 hours 40 sec ago

If the MIDI arrives at Logic, you might need to turn on input monitoring on that track.

marco56's picture
marco56
Offline
Last seen 2 months 3 weeks ago
Hi Andre, input monitoring does not appear as a button even if it is selected as icons in the configuration menu.
andre's picture
andre
Offline
Last seen 15 hours 40 sec ago

What happens when you connect the EWI to Logic directly?

marco56's picture
marco56
Offline
Last seen 2 months 3 weeks ago
Everything works. However, even if the driver is set on "out" and not on "in", selecting an instrument now also works with the Cognitone control. So now everything seems ok
Log in or register to post comments

Scholarly Lite is a free theme, contributed to the Drupal Community by More than Themes.