Yamaha. psr styles not loading in Synfire

5 posts / 0 new
Last post
janamdo's picture
janamdo
Offline
Last seen 3 weeks 2 hours ago

Yamaha. psr styles not loading in Synfire

In the past i cold load style file : .sty  in Synfire
Now the style format is chanced into .psr  annd cannot be loaded anymore direktly in Synfire 

Is it possible for Cognitone to get the Yamaha style format:  .psr... loaded into Synfire ?
 

 

janamdo's picture
janamdo
Offline
Last seen 3 weeks 2 hours ago

Good news !

Seems that .psr styles can be renamed to .sty without problems 
Their functioning stays the same.

It only adds Pro bedside the name on the keyboard.

janamdo's picture
janamdo
Offline
Last seen 3 weeks 2 hours ago

But there is a problem with the soundassigning of the .sty files
Don't get the right sound assigned after importing.

It are probably GM sounds for the accompaniment engine of the SX600 keyboard ?
If it are GM sounds then i do want to use Halion Sonic or Halion 6 fro GM sounds 

The .sty file does not asign the right sounds , so its not a GM file in Synfire 
If i import .psr file in Cubas the sounds are assigned correct to Halion sonic as it seems  

How to solve this : i don't think Cognitone will fix this by allowing importing this midi style file .psr with the right soundassigning ?

 

  

 

 
 

janamdo's picture
janamdo
Offline
Last seen 3 weeks 2 hours ago

Probably i must use the SX600 soundmodule connected with a soundrack in Synfire 
The styles are using advanced sound and replacing with other sounds is loss of quality

Therefore i can use a styleeditor for the styles to figure out what sounds are present in the style.
Possible is it also to make a device description for the SX600 soundmodule ?
As @blacksun explained you can fill tracks in Synfire up to 16 sounds manual ..but how to do for all sounds ?

A style is build up of 8 instrument , so one rack can houses two styles connected with SX600 soundmodule
Choose a style you like and compose with it   

 

janamdo's picture
janamdo
Offline
Last seen 3 weeks 2 hours ago

Can't get no access to all SX600 sounds : probably the sounds are divided in sound banks 
If i now  a banknumber then  can thi sadded to a device desription..or not ?

Log in or register to post comments

Scholarly Lite is a free theme, contributed to the Drupal Community by More than Themes.