Synfire 2.0.5

25 posts / 0 new
Last post
andre's picture
andre
Offline
Last seen 4 days 5 hours ago

Synfire 2.0.5

Finally, here's a huge update with lots of issues fixed and improvements made. I've highlighted a few prominent changes you might want to test.

  1. Windows: Popup menus open at wrong position on HiDPI monitors
  2. Windows: User bigger mouse cursors for tools from 150% upwards
  3. Windows: Graphics glitches with popup menus
  4. Windows: Drag & drop HiDPI issues
  5. Notation Export: Improved auto detection of pre-processing options
  6. Notation Export: Improved splitting of rests using more context
  7. Notation Export: Fixed issue with accidentals that shift across octave bounds
  8. Notation Export: Disabled export of accidentals by default (can be enabled where needed)
  9. Notation Export: Ignore up/down direction of a run when spelling chromatic notes
  10. Notation Export: Use full measure rests where applicable
  11. Notation Export: Fixed issue with incomplete MusicXML measures and rests
  12. Notation Export: Minimum exported rest length makes "Rests" switch redundant
  13. Notation Export: Per-instrument settings not always retained
  14. Notation Export: Fixed multiple issues with beaming and tuplets
  15. Notation Export: Fixed issue with lyrics export
  16. Notation Export: Improved preferences for launching compilers end editors
  17. Notation Export: Always export F# Major as Gb Major, D# Minor as Eb Minor
  18. Notation Export: Long rests should be split into beats under certain conditions
  19. Notation Export: Update file extension to .musicxml
  20. Length 5/8 should not display as something odd like 1/4**+1/16 (figure inspector)
  21. Dispay sequential interpolation w/o trailing values
  22. Make Skip parameter visible
  23. Drones should not be offered if already used by a different arrangement
  24. Fixed issues with external MIDI synchronization
  25. Fixed an issue with rack module relocation
  26. Embedded GM Synth should not be offered as external MIDI sync port
  27. Embedded GM Synth browser item should be disabled if already in usetreem
  28. Sound Wizard: Unable to select a preset for Drones
  29. Sound Wizard: Drones should be disabled if none available
  30. Sound Wizard: Input-only MIDI ports should not appear for selection
  31. Sound Wizard: Fixed several issues with selection
  32. Sound Wizard: Last used plug-in not remembered reliably
  33. Sound Wizard: Must not allow "Next" menu item is disabled
  34. Device created on rack not immediately recognized for next added plug-in instance
  35. Ability to forcibly claim a used Drone from a different arrangement
  36. Ability to switch Drone playback modes on rack module
  37. Fixed visibility issues with rack module library
  38. Snippets: Option to use 'Single-Phrase Snippets Only'
  39. Snippets: Improved grid layout and menus
  40. Snippets: Updated documentation and help
  41. Snippets: Undo should not backup every single snippet individually
  42. Editing: Show immediate result while moving objects
  43. Editing: Fixed dragging symbol lengths
  44. Editing: Fixed an error with display of metric grid in phrase editor
  45. Editing: Fixed issue with Step application to Figure at loop point
  46. Editing: Make grid display more intuitive
  47. Editing: Make room for negative symbol positions as needed
  48. Editing: Make keyboard shortcut for grid show/hide
  49. Editing: Rewrite Resample to yield better results for figures
  50. Editing: Rewrite legato and quanization algorithms for better results
  51. Editing: Rewrite stretching algorithm for figure segments (snap to grid)
  52. Editing: Shrinking a segment to the extreme should turn it into a chord
  53. Editing: Quantize Lengths in isolation doesn't make much sense musically (removed)
  54. Editing: Improved Clip Lengths results
  55. Editing: Add a Quantize button to Clickboard
  56. Transform >> Force Legato should assume a chord only where onsets are closer than 1/64
  57. New command Simplify Chords
  58. Show Grid should also be in View menu
  59. Saving keyboard shortcuts to HTML was broken (Windows)
  60. Copying or cloning an arrangement corrupted it
  61. Fixed odd value legend with Shift parameter
  62. Make zoom increments finer
  63. Updated system icons
  64. Factories: Playing ranges of segments got lost
  65. Fixed issue with Flow parameter resulting in clipped notes

As always, please report issues for this version in this thread. Thanks.

HiEnergy's picture
HiEnergy
Offline
Last seen 4 hours 49 min ago

Unfortunately I still get this error when starting Synfire.
synfire_error.png

Show Details gives this:

Exception Name: NSInternalInconsistencyException
Description: Menu should have been unscheduled for updating
User Info: {
    NSAssertFile = "NSMenuItem.m";
    NSAssertLine = 4354;
}

0   CoreFoundation                      0x00007ff81895f7b3 __exceptionPreprocess + 242
1   libobjc.A.dylib                     0x00007ff8186bfbc3 objc_exception_throw + 48
2   Foundation                          0x00007ff819811d13 -[NSAssertionHandler handleFailureInMethod:object:file:lineNumber:description:] + 267
3   AppKit                              0x00007ff81b9649b4 __35-[_NSMenuShortcutUpdater schedule:]_block_invoke + 206
4   CoreFoundation                      0x00007ff8188e3d31 __CFRUNLOOP_IS_CALLING_OUT_TO_A_BLOCK__ + 12
5   CoreFoundation                      0x00007ff8188e3bdc __CFRunLoopDoBlocks + 445
6   CoreFoundation                      0x00007ff8188e2f4d __CFRunLoopRun + 2609
7   CoreFoundation                      0x00007ff8188e1e5c CFRunLoopRunSpecific + 562
8   HIToolbox                           0x00007ff8215895e6 RunCurrentEventLoopInMode + 292
9   HIToolbox                           0x00007ff82158934a ReceiveNextEventCommon + 594
10  HIToolbox                           0x00007ff8215890e5 _BlockUntilNextEventMatchingListInModeWithFilter + 70
11  AppKit                              0x00007ff81b3211fd _DPSNextEvent + 927
12  AppKit                              0x00007ff81b31f8ba -[NSApplication(NSEvent) _nextEventMatchingEventMask:untilDate:inMode:dequeue:] + 1394
13  AppKit                              0x00007ff81b311f69 -[NSApplication run] + 586
14  AppKit                              0x00007ff81b2e5ee7 NSApplicationMain + 817
15  mps                                 0x00000001000a0be7 oeMain + 567
16  dyld                                0x000000010eb4651e start + 462

 

The hardware I'm running Synfire on is this:

Hardware Overview:

  Model Name: iMac
  Model Identifier: iMac19,1
  Processor Name: 6-Core Intel Core i5
  Processor Speed: 3,7 GHz
  Number of Processors: 1
  Total Number of Cores: 6
  L2 Cache (per Core): 256 KB
  L3 Cache: 9 MB
  Memory: 64 GB
  System Firmware Version: 1731.120.8.0.0
  OS Loader Version: 540.120.3~6
  SMC Version (system): 2.46f13

The operating system is MacOS 12.4 (Monterey) 

Attachments: 
andre's picture
andre
Offline
Last seen 4 days 5 hours ago

Thanks. The description seems clear, although the menu is already being unscheduled for updating so I have no idea yet. 

Do you get this immediately on launch, or some time later when you access the menu bar?

HiEnergy's picture
HiEnergy
Offline
Last seen 4 hours 49 min ago

It appears before the main window (empty arrangement) finishes drawing.

HiEnergy's picture
HiEnergy
Offline
Last seen 4 hours 49 min ago

I forgot to say that choosing "Crash" in the error dialog doesn't visibly crash anything for me. The dialog then just disappears. Perhaps the error is produced by a program part that has already terminated when the main window finishes drawing and I get to dismiss the dialog.

Is there a possibility of me running Synfire with the Audio Engine disabled being a part of the problem?
Enabling the Engine makes the error go away.

andre's picture
andre
Offline
Last seen 4 days 5 hours ago

Thanks for the video. I don't think it has to do with the Audio Engine, but it may be a side effect of a delay caused by launching it at startup. It should be an easy fix once I can reproduce it (not yet).

scriabiner's picture
scriabiner
Offline
Last seen 1 hour 5 min ago

At least for Windows, the installer for build #3 is actually the installer for #2.

andre's picture
andre
Offline
Last seen 4 days 5 hours ago

It's possible the build counter wasn't properly incremented. Build #3 makes a significant difference vs. #2. So just to be sure, I ran a rebuild and uploaded that. Thanks for reporting.

scriabiner's picture
scriabiner
Offline
Last seen 1 hour 5 min ago

Fix confirmed.

scriabiner's picture
scriabiner
Offline
Last seen 1 hour 5 min ago

So, first, the Undo/Redo functions are still completely messed up and you lose entire Figures when using them.
I'm saying this because I thought it was fixed, but maybe it was only for the arrangement, I don't know. It's in this state since V1, I suppose users are used to save their projects like every minute and make thousands of versions.

Moreover, please consider clearing confusion with the Grid parameter: https://users.cognitone.com/comment/19947#comment-19947

Windows: Graphics glitches with popup menus

They still go outside of the screen though; that one is the most annoying thing. Thinking about it, I don't remember this happening in V1. What's the deal?

Notation Export: Improved auto detection of pre-processing options

I can see a general improvement. I still get some weird results with actual music (stuff not just for testing), but I'll have to look at that more carefully, so I can maybe post some some examples. But it's probably because there are tuplets that are still not supported because of the resolution. Does factories create such tuplets? And therefore you can't export them?

Anyway, at first I got a complete mess until I realized that it detected 2 voiced in a single voice instrument, so I manually fixed that and it was generally ok: I would just disable that useless option, honestly, since you're going to have to give support for used-defined voices anyway, otherwise keyboard music will always be impossible to make with Synfire. More in my list of suggestions thread, first section, for a long explanation about this issue; certain things have already been touched in the export-to-notation thread.

By the way, what's the point of "Show Grid" in the Progression tab?

Notation Export: accidentals and spelling

Thank you.

Notation Export: Improved preferences for launching compilers end editors

Seems fixed now. It's very useful to immediately see the result.

Notation Export: Always export F# Major as Gb Major, D# Minor as Eb Minor

Good. Standard, and easily changed via notation programs.

Editing: Make grid display more intuitive

You mean different vertical line colors? Thank you! It makes all the difference.

Editing: Fixed dragging symbol lengths

Editing: Make keyboard shortcut for grid show/hide

Editing: Add a Quantize button to Clickboard

Great.

In the progression tab, this looks like a bug though: https://users.cognitone.com/files/forum/3689/progression_tab_empty_secti...

Editing: Rewrite stretching algorithm for figure segments (snap to grid)

Editing: Shrinking a segment to the extreme should turn it into a chord

Awesome.

andre's picture
andre
Offline
Last seen 4 days 5 hours ago

Can you give an example where Undo/Redo messes up?

The only issue I know of is that Undo/Redo menu items sometimes get disabled (which blocks the keyboard command, too) because the original widget lost focus. Clicking on the widget (parameter editor, outlet, container, whatever) will enable the items again.

scriabiner's picture
scriabiner
Offline
Last seen 1 hour 5 min ago

No, it's not about the focus issue.

Just try to split figures and copy & paste figures around.

I've sent en email with one example.

scriabiner's picture
scriabiner
Offline
Last seen 1 hour 5 min ago

For some reason, the option "Merge phrases" doesn't work anymore. It only works after you've immediately splitted a figure; just clicking another container and coming back, it doesn't work anymore.

From 2.0.5, or maybe some versions before (noticed now), with any level of horizontal zoom, the focus on the selected point is lost. Before, it happened only with a very high horizontal zoom.

 

andre's picture
andre
Offline
Last seen 4 days 5 hours ago

"Merge phrases" doesn't work anymore

You need to select multiple phrases for the same instrument. The phrase is merged into the phrase that is selected first. The issue is probably that a right-click for the menu happens to make a new single-selection. Using the command from the menu bar works.

scriabiner's picture
scriabiner
Offline
Last seen 1 hour 5 min ago

Oh ok, that's it. Because I expected to find the option in the popup menu.

juergen's picture
juergen
Offline
Last seen 1 week 4 days ago

I can't get sketches running. Either it crashes or it just opens an empty sketch.

 

discosleepy's picture
discosleepy
Offline
Last seen 2 weeks 5 days ago

Many bugs were fixed. Thanks.

The most annoying bug left open for me refers to Audio Engine. Sound breaks from time to time. The longer you work, to more often sound is broken. After some time every minute. I think this bug was already reported.

Here are some details: you can  get sound back, if you are changing Audio Device Driver (Back and Forth). Then sound is back again without  anything to do in Synfire Plackback. Currently playing arrangment   will sound again, without pressing play again. So i think it must be an Audio Engine issue  only. I have tried Windows Audio,  DirectSound, ASIO Drivers from Focusrite, Yamaha,... ...no difference. So  it does not seem to be a driver issue. Must be something in Audio Engine, I guess.

Unfortunately you cannot let the window for device driver selection left open, because then plugin dialogs from Audio Engine cannot be used. So you have to close and reopen the dialog "Audioeinstellungen" everytime this happens...

Komposure318's picture
Komposure318
Offline
Last seen 1 week 6 days ago

Im having a issue with the buttons not showing up on my desktop but it works fine on my laptop.

Attachments: 
discosleepy's picture
discosleepy
Offline
Last seen 2 weeks 5 days ago

It should not be needed, but the following workaround worked for me:

1. Go to the Synfire installation folder
2. Open the Fonts folder
3. Open each of the fonts in this folder
4. Press "Install" to install each font permanently in Windows
5. Close and reopen Syfire

The symbols should be then all visible. Have fun :-)

duderanch's picture
duderanch
Offline
Last seen 5 days 14 hours ago

I am having these same issues.  

Komposure318's picture
Komposure318
Offline
Last seen 1 week 6 days ago

This worked, Thanks alot

andre's picture
andre
Offline
Last seen 4 days 5 hours ago

The Windows platform is an unpredictable mess. No matter how hard you test, how painstakingly you adhere to guidelines and de facto standards, there are always PCs out there for which something doesn't work for no apparent reason. This is such a pain in the butt, we briefly considered ditching the platform altogether. Doing away with 50% of the market however is not an option, so no worries ;-) I wonder if Microsoft will ever leave the 1980's behind and come up with something fresh that is not a never ending patchwork of layers over layers of workarounds.

Installing the fonts should not be necessary, but if it fixes the issue, so be it. If you do so, please do so with every update, or any new icons won't show up.

csfigu's picture
csfigu
Offline
Last seen 1 month 2 weeks ago

Hi Andre,

I am on Mac and the Midi tempo TAP button seems to do... nothing. does not change tempo. Anyone else noticed this?

Ruchir's picture
Ruchir
Offline
Last seen 3 weeks 17 hours ago

Maybe a browser based version of Synfire using the html5 standard.

andre's picture
andre
Offline
Last seen 4 days 5 hours ago

The fonts issue on Windows and most other reported problems should be resolved with 2.0.6 now.

Log in or register to post comments

Scholarly Lite is a free theme, contributed to the Drupal Community by More than Themes.