Synfire 1.9 Beta

155 posts / 0 new
Last post
valsolim's picture
valsolim
Offline
Last seen 2 months 3 weeks ago

Hello, Andre,

I have some positive news about Synfire 1.9: A) ReWire synchronization with Steinberg Cubase 9.5.41 finally works, and B) Unicode support is there as well!

A nice Christmas present, thanks so much :-)

Miloslav

P.S.: Interestingly enough, ReWire synchronization with PreSonus Studio One 4.1.1 works as well, even though SO insists that "No DAW with a Transport found".

Ruchir's picture
Ruchir
Offline
Last seen 8 hours 41 min ago

Hi. I unzipped and put in the folder mentioned above - then relaunched Synfire Pro - same error.

Do I need to reinstall?

valsolim's picture
valsolim
Offline
Last seen 2 months 3 weeks ago

I suspect there is a problem that the Synfire 1.9 Beta installer modifies the previous 1.8.5 installation, therefore, the two versions are actually not prepared to coexist together (on Windows, at least). So, I would suggest you to uninstall both and then install just one version at the same time.

Ruchir's picture
Ruchir
Offline
Last seen 8 hours 41 min ago

Right in the middle of this at the moment. Uninstalled both. Resinstalled the previous 1.8.5 (latest version).

It hangs on "Starting Audio Engine" then after a while says the Audio Engine does not report back. Tried this a couple of times including restarting the computer. (Even when turning off the firewall for ther lan network)

Looks like I can't go back to 1.8.

valsolim's picture
valsolim
Offline
Last seen 2 months 3 weeks ago

If you are on Windows, go to your "Programs and Features" and have a look at everything starting with "Cognitone". It is possible that you have an incompatible version of Cognitone Audio Engine installed. Try to uninstall everything "Cognitone" directly from Programs and Features, instead of "Start Button -> Cognitone -> Setup, Activation or Uninstall".

Ruchir's picture
Ruchir
Offline
Last seen 8 hours 41 min ago

Thanks - after some registry hunting I got rid of everything Cognitone, and then reinstalled 1.8.5 (latest version) which worked.

Then I applied the new patch - which worked applied fine.

Then I resinstalled 1.9 beta, and now I'm back to square one with the problems faced by 1.8.5. The patch doesn't fix whatever is stopping 1.8.5 starting when 1.9 is installed on my system.

Two hints:

It gets stuck with user.prefs

If that's removed, it gets stuck with Starting Audio Engine.

andre's picture
andre
Offline
Last seen 2 days 16 hours ago

As said, you'd need to backup your "Config" folder and restore it after you return. Synfire saves all sorts of information, some of which contains date and time, the format of which has changed. It loads the patch after it loaded your prefs (which is why deleting the prefs helped). Audio Engine is 3.0 now, so you'd also need to reinstall version 2.x, or Synfire can't connect.

Admittedly this back and forth is a bit bumby, but once 1.9 will be stable, there is no more reason to return to 1.8.  

A new build of 1.9 is already online now.

We will be addressing remaining issues immediately after Christmas.

Ruchir's picture
Ruchir
Offline
Last seen 8 hours 41 min ago

Thanks Andre.

I did indeed backup my config folder so no problem there.

My issue is I can't get the two versions to coexist on my system.

I've opted to hold on to 1.9 for now as I'm not currently engaged in any composition projects.

Hope the above description of the issue helps in tracking the bugs.

Thanks, Ruchir.

andre's picture
andre
Offline
Last seen 2 days 16 hours ago

After an initial hickup, build #41 should be stable for now.

RobertoD's picture
RobertoD
Offline
Last seen 14 hours 32 min ago

can't set the pre-roll

iMac Pro, Logic Pro, StudioOne 4, Synfire, Notion, NI Komplete, Heavyocity, various Spitfire/8Dio/VSL libs, Altiverb, a mate (Ines) and two cats (Oliva&Spritzi)

RobertoD's picture
RobertoD
Offline
Last seen 14 hours 32 min ago

Have you planned customizable shortcuts? it's a little mess: in 1.8 some keys worked as shortcuts. In 1.9 nomore :-(

iMac Pro, Logic Pro, StudioOne 4, Synfire, Notion, NI Komplete, Heavyocity, various Spitfire/8Dio/VSL libs, Altiverb, a mate (Ines) and two cats (Oliva&Spritzi)

andre's picture
andre
Offline
Last seen 2 days 16 hours ago

Have you planned customizable shortcuts?

Yes.

RobertoD's picture
RobertoD
Offline
Last seen 14 hours 32 min ago

It looks as if pencil tool draws one line above the pencil point

still there 

iMac Pro, Logic Pro, StudioOne 4, Synfire, Notion, NI Komplete, Heavyocity, various Spitfire/8Dio/VSL libs, Altiverb, a mate (Ines) and two cats (Oliva&Spritzi)

RobertoD's picture
RobertoD
Offline
Last seen 14 hours 32 min ago

the app info says build #39

Shouldn't it be #41? 

image1.png 

Attachments: 

iMac Pro, Logic Pro, StudioOne 4, Synfire, Notion, NI Komplete, Heavyocity, various Spitfire/8Dio/VSL libs, Altiverb, a mate (Ines) and two cats (Oliva&Spritzi)

andre's picture
andre
Offline
Last seen 2 days 16 hours ago

Yes, it should be #41. Did you confuse your downloaded files?

The pencil tip hits the lines here. What am I missing?

RobertoD's picture
RobertoD
Offline
Last seen 14 hours 32 min ago

Yes, it should be #41. Did you confuse your downloaded files?

The download link says #41, but the installer says #39 and at the end of the installation I have a #39 on my Mac.

image1.png

image2.png 

Attachments: 

iMac Pro, Logic Pro, StudioOne 4, Synfire, Notion, NI Komplete, Heavyocity, various Spitfire/8Dio/VSL libs, Altiverb, a mate (Ines) and two cats (Oliva&Spritzi)

RobertoD's picture
RobertoD
Offline
Last seen 14 hours 32 min ago

The pencil tip hits the lines here. What am I missing?

See the attached screen recording.

(v. 1.8 worked fine)

image1.gif 

Attachments: 

iMac Pro, Logic Pro, StudioOne 4, Synfire, Notion, NI Komplete, Heavyocity, various Spitfire/8Dio/VSL libs, Altiverb, a mate (Ines) and two cats (Oliva&Spritzi)

ryland's picture
ryland
Offline
Last seen 2 months 1 week ago

On Mac it is also diffcult to save new arrangement, and it is as said above about to insert with pencil.

Tanerongunyzb's picture
Tanerongunyzb
Offline
Last seen 1 month 2 days ago

Hi Andre, I also installed new version and installer says #39 and at the end of the installation I have a #39 on my Mac .

andre's picture
andre
Offline
Last seen 2 days 16 hours ago

On Mac it is also diffcult to save new arrangement

How exactly?

ryland's picture
ryland
Offline
Last seen 2 months 1 week ago

Hi Andre When I save I got this popup window. Unhandled expection: improper store into indexable store.

 

Attachments: 
Tanerongunyzb's picture
Tanerongunyzb
Offline
Last seen 1 month 2 days ago

Hi Andre, I have also same problem. (Save setings)

RobertoD's picture
RobertoD
Offline
Last seen 14 hours 32 min ago

For some reason the chord indicated by the yellow arrow is inactive

image1.png

Attachments: 

iMac Pro, Logic Pro, StudioOne 4, Synfire, Notion, NI Komplete, Heavyocity, various Spitfire/8Dio/VSL libs, Altiverb, a mate (Ines) and two cats (Oliva&Spritzi)

RobertoD's picture
RobertoD
Offline
Last seen 14 hours 32 min ago

After pressing spacebar o clicking on "Play", the playhead will jump backward, before measure 1, then will begin to play. But, often, the first note of the top track will not play.

image1.gif

Attachments: 

iMac Pro, Logic Pro, StudioOne 4, Synfire, Notion, NI Komplete, Heavyocity, various Spitfire/8Dio/VSL libs, Altiverb, a mate (Ines) and two cats (Oliva&Spritzi)

andre's picture
andre
Offline
Last seen 2 days 16 hours ago

My bad. I happened to forget to unlock the last Mac build. Whatever, #46 is now online. Most of what you reported should be fixed now.

ryland's picture
ryland
Offline
Last seen 2 months 1 week ago

The new update took away the older few issue but brings a few new, the shortcuts for tools don’t work anymore   
and after tape in duration for symbols the shortcuts for transport don’t work stop or play. The visibly of note duration still don’t work.
Suggestion for tool shortcuts is to set one key for to quick change between one shot pencil tool to one select one tool, example while you are in pencil tool, hit shortcuts and the tool change to select tool and when you loss the shortcuts the tool go back to original tool.
I think the shortcuts for tools should be near the spacebar  key and even the stop key should be near the spacebar to stop to many hands moments.

RobertoD's picture
RobertoD
Offline
Last seen 14 hours 32 min ago

and after tape in duration for symbols the shortcuts for transport don’t work stop or play. The visibly of note duration still don’t work.

I have just discovered the only two shortcuts that work (here).

The comma ( , ) will play only the selected instrument(s), while the period ( .  will start a new recording.

 

iMac Pro, Logic Pro, StudioOne 4, Synfire, Notion, NI Komplete, Heavyocity, various Spitfire/8Dio/VSL libs, Altiverb, a mate (Ines) and two cats (Oliva&Spritzi)

RobertoD's picture
RobertoD
Offline
Last seen 14 hours 32 min ago

With regard to shortcuts, I would like the Undo/Redo and Transport to be Global, not tightly linked to the active panel or parameter.

Otherwise, most of the time, they will seem not to work just because you selected a different window or parameter!

iMac Pro, Logic Pro, StudioOne 4, Synfire, Notion, NI Komplete, Heavyocity, various Spitfire/8Dio/VSL libs, Altiverb, a mate (Ines) and two cats (Oliva&Spritzi)

RobertoD's picture
RobertoD
Offline
Last seen 14 hours 32 min ago

Beside, please, when one clicks the rewind button, the "arranger" window should go to the beginning rather staying where it has been left on stop

iMac Pro, Logic Pro, StudioOne 4, Synfire, Notion, NI Komplete, Heavyocity, various Spitfire/8Dio/VSL libs, Altiverb, a mate (Ines) and two cats (Oliva&Spritzi)

andre's picture
andre
Offline
Last seen 2 days 16 hours ago

The shortcuts are somewhat tricky. There is no way the spacebar could work for playback while a text field has input focus. How would Synfire tell whether you wanted a space character inserted or the playback started? Similarly for checkboxes and popup menus, where the spacebar opens or selects them. Whatever control currently has focus decides whether to respond to input or pass it on to the next higher control.

For the transport to respond, you need to focus (click) a control that does not interpret the keyboard otherwise.

Pages

Log in or register to post comments

Scholarly Lite is a free theme, contributed to the Drupal Community by More than Themes.