Synfire 1.9 Beta

93 posts / 0 new
Last post
RobertoD's picture
RobertoD
Offline
Last seen 2 days 9 hours ago

[OT MODE ON] :-)

please Andre consider adding the option of pause/activate any parameter

[OT MODE OFF]

iMac Pro, Logic Pro, StudioOne 4, Synfire, Notion, NI Komplete, Heavyocity, Altiverb, a mate (Ines) and two cats (Oliva&Spritz)

RobertoD's picture
RobertoD
Offline
Last seen 2 days 9 hours ago

The shortcuts are somewhat tricky. There is no way the spacebar could work for playback while a text field has input focus. How would Synfire tell whether you wanted a space character inserted or the playback started?

in this case you must keep things separated: when you focus a text field the spacebar operates as spacebar into that field. But when you leave the field or hit Enter it should operate as a play/stop button

iMac Pro, Logic Pro, StudioOne 4, Synfire, Notion, NI Komplete, Heavyocity, Altiverb, a mate (Ines) and two cats (Oliva&Spritz)

andre's picture
andre
Offline
Last seen 1 day 2 hours ago

But when you leave the field or hit Enter it should operate as a play/stop button

That's how it is supposed to work. Unless Enter takes you to the next text field.

Iratecaller's picture
Iratecaller
Offline
Last seen 2 weeks 16 hours ago

Issue: 100% Crashes and/or critical errors attempting "live chord detection".

Steps: Hit record, play keyboard with three notes, stop record, crash. No live detection whatsoever.

I never tried it prior to 1.9, so I'm not sure it worked prior.

Systems: Windows 10, latest version, multiple machines, AMD and Intel processors, more RAM than you can shake a stick at. Plenty of hard drive space.

Controllers: M-Audio keystation 61, and some Korg microKey air 25, Fishman Tripleplay

 

Tanerongunyzb's picture
Tanerongunyzb
Offline
Last seen 22 hours 42 min ago

Hi Andre, new updated is something new problem.  First of all drag and drop phrase couldn’t work . Also Transport problem.  And live chord detection don’t stop sometimes. All people of the forum “ Happy new year. “

andre's picture
andre
Offline
Last seen 1 day 2 hours ago

Thanks for your reporting so far. We will be back at work on January 2 and fix it.

Wish everyone a happy new year.

jigglypuff's picture
jigglypuff
Offline
Last seen 1 week 6 days ago

I can confirm that live chord detection does not crash on 1.8.5 build #5 on MacOS 10.14.2.

Iratecaller's picture
Iratecaller
Offline
Last seen 2 weeks 16 hours ago

Thank you for confirming.

RobertoD's picture
RobertoD
Offline
Last seen 2 days 9 hours ago

Apart from when clicking on a chord into the Palette, the Harmonic Context window doesn't work, either in Arrange tab or in Progression tab

 

iMac Pro, Mojave 10.14.2, Synfire 1.9 #46

iMac Pro, Logic Pro, StudioOne 4, Synfire, Notion, NI Komplete, Heavyocity, Altiverb, a mate (Ines) and two cats (Oliva&Spritz)

andre's picture
andre
Offline
Last seen 1 day 2 hours ago

So here I emerge again from the deep bottom of the code of Synfire, like a beaten horse, with a new build:
https://www.cognitone.com/user/downloads/index.stml

What first looked like simple to fix bugs, happened to send me down a rabbit hole, entailing a partial rewrite of vital user interface components. Sometimes things need to be torn apart and built up again to get it right. 

There is at least one thing left: The often slow start at the beginning of a playback. It is not yet clear what causes this. I hope to get to the bottom of it (again) next week.

Iratecaller's picture
Iratecaller
Offline
Last seen 2 weeks 16 hours ago

Tried to download a device description from the online repo.  Crashes and fails every single time.

I just click on "Download Device" , then the "fetching" progress bar seems to be at the 25% mark .. and boom ... crash. 

Clicking on "continue" after that leads to nothing.  No device downloaded.

Bummer.

Tanerongunyzb's picture
Tanerongunyzb
Offline
Last seen 22 hours 42 min ago

First of all thanks Andre. I checked it quickly. All problem who has said have solved,  only when symbol is First (Start ) note of measure Sometimes It doesn't play. I find the other problem but It's not version problem I think.  When I checked interpretation Voice Leading mode is always same midi note (chords only ) and (chords with extension ) between this two choise.  If I find new problem I wrote it. Thanks again.

stygmate's picture
stygmate
Offline
Last seen 1 week 4 days ago

Hi,

I have a bug on mac with beta of 1.9.

When i push play in harmonizer and stop, the sound is stopped but the position bar keep running and all graphical elements keep updating accordingly to the ghost play.

After playing and stopping some times i begin to have other glitch like indention pushing list of possible chord more and more to the right.

stygmate's picture
stygmate
Offline
Last seen 1 week 4 days ago

you can see it a the end of this animation:

 

ryland's picture
ryland
Offline
Last seen 1 week 4 days ago

Hi, I tryed to save an arrangement to standard midi file but the same popup window turn up as before, I could save the arrangement as normal thats good. Now I know thats is my Mac pro 12 how don't save as midi file, but my Macbook 12 work as it should. Strange!

andre's picture
andre
Offline
Last seen 1 day 2 hours ago

Thanks for your incoming reports. I'm currently working on an bigger Audio Engine fix that does away with the playback delays and DAW sync issues. This will speed up things noticeably and make Synfire more fun to use. Hope to get it done by end of the week.

RobertoD's picture
RobertoD
Offline
Last seen 2 days 9 hours ago

Tried to add an Fmaj7 to the current wholetone palette 

image1.png

but Synfire did not add anyting

image2.png

iMac Pro, Logic Pro, StudioOne 4, Synfire, Notion, NI Komplete, Heavyocity, Altiverb, a mate (Ines) and two cats (Oliva&Spritz)

RobertoD's picture
RobertoD
Offline
Last seen 2 days 9 hours ago

if you enable the Live Chord detection checkbox, play any chord then disable it, you get a "nil" value quite ugly to be seen ;-)

image1.png

Attachments: 

iMac Pro, Logic Pro, StudioOne 4, Synfire, Notion, NI Komplete, Heavyocity, Altiverb, a mate (Ines) and two cats (Oliva&Spritz)

andre's picture
andre
Offline
Last seen 1 day 2 hours ago

Thanks for your ongoing reports. 

Status update:

Meanwhile the fixes of the Audio Engine turned into a medium size restructuring. Timing and communication between the components had to be redesigned. There is still some work to do, but we are getting closer. Next version 3.1.0 will be a major step forward with much better auto-tuning to latencies and a more responsive playback. It will be worth the wait. I'm sorry for the current beta's choppy playback and laggy response. Remedy is already in sight ... the new engine already feels totally different.

RobertoD's picture
RobertoD
Offline
Last seen 2 days 9 hours ago

In the Progression tab the harmonic context window will not show anything if clicking on a chord

image1.gif

 

++EDIT: It works again if quitting and restarting Synfire, but not always. Right now, for example, I quitted and relaunched Synfire and opened an existing project, but there is no way to make the harmonic context window work again

++EDIT2: oh, I found the issue. The Harmonic Context and Cricle of Fifths window works only if the playback button (the top right loudspeaker icon) is ON. What is the meaning of this limitation? :-|

Attachments: 

iMac Pro, Logic Pro, StudioOne 4, Synfire, Notion, NI Komplete, Heavyocity, Altiverb, a mate (Ines) and two cats (Oliva&Spritz)

andre's picture
andre
Offline
Last seen 1 day 2 hours ago

Tried to add an Fmaj7 to the current wholetone palette

That chord is probably outside the scales. You'll need to tell the layout that it also show outside chords (Layout menu).

What is the meaning of this limitation? 

The panel shows what is currently playing. If instant feedback is off, nothing is shown because nothing is playing. It's different with the palette, though. Maybe it should work the same with progressions ...

BTW: Next update is getting closer ;-)

Tanerongunyzb's picture
Tanerongunyzb
Offline
Last seen 22 hours 42 min ago

Hi Andre; First of all thanks for great support. I find a problem. If I want to enter some chord by using chord detection Synfire pro doesn't accept chords as I play. Such as (Am) If I enter A3- C3-E3 Synfire pro accept A1-E2-C4 . And also same problem the other entry to use chord detection. I think same problem has occured not to use chord detection. Thanks a lot.

Tanerongunyzb's picture
Tanerongunyzb
Offline
Last seen 22 hours 42 min ago

And also by using palette some notes are green. Some notes are blue. When I play three notes Palette screen has shown six notes.

Tanerongunyzb's picture
Tanerongunyzb
Offline
Last seen 22 hours 42 min ago

I found interesting problem. When I have opened drone as a AU in logic    Logic had imediately crushed. But When I open drone as a VST in logic. There is no problem for logic.   Also Andre ! Can you look at synchorized problem DAW and Synfire Pro.  For Example Logic and Synfire Pro. Thanks again.

andre's picture
andre
Offline
Last seen 1 day 2 hours ago

The whole timing and sync has been rewritten in part, which is why the update took that long. Next Engine version 3.1 will work fine with Logic X. As it happens, we use Logic X as our primary host for development and debugging.

RobertoD's picture
RobertoD
Offline
Last seen 2 days 9 hours ago

BTW: Next update is getting closer ;-)

Thumbs up :-) 

iMac Pro, Logic Pro, StudioOne 4, Synfire, Notion, NI Komplete, Heavyocity, Altiverb, a mate (Ines) and two cats (Oliva&Spritz)

andre's picture
andre
Offline
Last seen 1 day 2 hours ago

New builds with new Audio Engine are online for download now:
https://www.cognitone.com/user/downloads/index.stml

Tanerongunyzb's picture
Tanerongunyzb
Offline
Last seen 22 hours 42 min ago

Hi Andre, Synchrosization problem is solved. But I think Palette problem is not solved.  If Any chords use live chord detection or not  Instrument sound is destroyed.  I have to use panic button. Would you look at Palette ? Thanks.

Tanerongunyzb's picture
Tanerongunyzb
Offline
Last seen 22 hours 42 min ago

Hi Andre, Synchrosization problem is solved. But I think Palette problem is not solved.  If Any chords use live chord detection or not  Instrument sound is destroyed.  I have to use panic button. Would you look at Palette ? Thanks.

Tanerongunyzb's picture
Tanerongunyzb
Offline
Last seen 22 hours 42 min ago

Hi Andre, Synchrosization problem is solved. But I think Palette problem is not solved.  If Any chords use live chord detection or not  Instrument sound is destroyed.  I have to use panic button. Would you look at Palette ? Thanks.

Pages

Log in or register to post comments

Scholarly Lite is a free theme, contributed to the Drupal Community by More than Themes.