Synfire 1.9 Beta

167 posts / 0 new
Last post
blacksun's picture
blacksun
Offline
Last seen 12 hours 57 min ago

please keep the external libraries, I use them all the time.

HiEnergy's picture
HiEnergy
Offline
Last seen 2 weeks 1 hour ago

I fully agree with Blacksun. I use phrases from external libraries for almost every project.

Please keep those.

RobertoD's picture
RobertoD
Offline
Last seen 5 months 2 weeks ago

I don't understand the reason for separating libraries from projects. Instead of having two hundred projects and two hundred libraries scattered everywhere you have only two hundred projects each with their own library exportable in any other project. Softwares with a separate window for each function are relics from the past (does anyone remember the Unity sampler?)  :-)

iMac Pro, Logic Pro, StudioOne 4, Synfire, Notion, NI Komplete, Heavyocity, various Spitfire/8Dio/VSL libs, Altiverb, a mate (Ines) and two cats (Oliva&Spritzi)

blacksun's picture
blacksun
Offline
Last seen 12 hours 57 min ago

I store my libraries organised by musical type, well sort of. I do have some specialist ones dedicated to individual instruments like drum patterns, guitar rifts..... With the workflow I use, any tune that uses drums will use phrases from the drum library, all trance songs will use some bass and lead phrases from my trance library, and probably chord progressions too. This isnt rigid I might use some phrases from a classical library, but maybe get the timing from a pattern in the trance library or one of the drum patterns. So I probably have about 20 or so libraries and they are used to make up most of my songs. I still make use of the embedded library however as a sort of scratch pad. 

scrybz's picture
scrybz
Offline
Last seen 6 months 1 week ago

I don't use "File -> New -> Library," but I use "Book Symbol -> Gear Symbol -> Create New Library . . . ." all the time.

You're only talking about the "File" menu option, right?

scrybz's picture
scrybz
Offline
Last seen 6 months 1 week ago

agreed wholeheartedly.  Different plugins need different styles of phrases, and it makes sense to keep them all together in a library devoted to the plugin. It would be a nightmare to have to go digging through different projects to find what I need.

RobertoD's picture
RobertoD
Offline
Last seen 5 months 2 weeks ago

It is more convenient then to use a single pool shared among all projects (like Apple loops in Logic) and search through a search window, then group items by category, plugins, etc. 

iMac Pro, Logic Pro, StudioOne 4, Synfire, Notion, NI Komplete, Heavyocity, various Spitfire/8Dio/VSL libs, Altiverb, a mate (Ines) and two cats (Oliva&Spritzi)

RobertoD's picture
RobertoD
Offline
Last seen 5 months 2 weeks ago

The goal should be to work as much as possible in the same window. That doesn't mean I can't export parts of the pool as a single file, if I want to do it (even if I don't see the reason)

iMac Pro, Logic Pro, StudioOne 4, Synfire, Notion, NI Komplete, Heavyocity, various Spitfire/8Dio/VSL libs, Altiverb, a mate (Ines) and two cats (Oliva&Spritzi)

andre's picture
andre
Offline
Last seen 14 hours 29 min ago

I like the idea of having all libraries in a searchable database, showing up in the embedded library space of an arrange window. Reducing the number of split views there is also a great idea. But, in whatever form of organization, libraries are at the core of music prototyping (some users have hundreds of them), so hiding them away in individual projects doesn't make sense.

That's for the "using" part of the workflow. The arrange window is not a good place to edit a library however. So the library editor won't go away. If only as an authoring tool for library creators.

BTW, we are getting off topic. This is an interesting discussion to have in a separate thread.

RobertoD's picture
RobertoD
Offline
Last seen 5 months 2 weeks ago

This will be my last OT post :-)

Could you add a search window and some grouping criterion to the libraries? 
If the external libraries remain, I suggest two new features:
1. A search window both in the floating libraries and in the library embedded into the arrangement, so one can create and store a unique and searchable library common to all projects;
2. a new menu voice: File > Save as Template

iMac Pro, Logic Pro, StudioOne 4, Synfire, Notion, NI Komplete, Heavyocity, various Spitfire/8Dio/VSL libs, Altiverb, a mate (Ines) and two cats (Oliva&Spritzi)

larry's picture
larry
Offline
Last seen 7 months 12 hours ago

Question where do i download synfire at im confused

larry smalls

andre's picture
andre
Offline
Last seen 14 hours 29 min ago

Download here: https://www.cognitone.com/user/downloads/index.stml

As for the Scaleboard locking up, how can I reproduce? Or does it happen randomly?

yaSteve's picture
yaSteve
Offline
Last seen 6 months 4 weeks ago

1.9

When using a 4K monitor VST plugin UIs are tiny. They were much larger in 1.8.5. Please  make them larger so can be read more easily.

yaSteve's picture
yaSteve
Offline
Last seen 6 months 4 weeks ago

Fresh install of 1.9

The enabled MIDI input does not work when starting Synfire. In this case it is a Parnorama P6 keyboard. I have to go to the Audio & MIDI Setup -> Inputs tab and unselect/ then reselect to make it work.

andre's picture
andre
Offline
Last seen 14 hours 29 min ago

The enabled MIDI input does not work when starting Synfire

This is a Windows issue with non-multi-client capable USB drivers. Another software probably holds onto the MIDI keyboard already (DAW?), so Synfire needs to forcibly re-take it. Not pretty, but nothing we could do much about, unfortunately. You have a similar issue when you put your DAW back into the foreground?

 

sksherman's picture
sksherman
Offline
Last seen 4 months 2 weeks ago

So, what is the trick to getting mps-1.9b31 to install on Windows 8.1? 

I fully deinstalled 1.8.5 and 1.9, removed all references to Cognitone from the registry and modified all the install files to be compatible with previous versions.  The Setup was modified to be compatible with both Windows 7 and Windows 8 (two different attempts).  (Anti-virus is off and everything is run with admin privs, of course.)  I still get the hang and eventual fail where it tells me to continue SETUP in the next window.  I only have it installing the 64-bit version of the Audio Engine. 

Of course, 1.8.5 didn't have this issue and that window comes up.

Thanks!  :)

Steve

HiEnergy's picture
HiEnergy
Offline
Last seen 2 weeks 1 hour ago

I managed to get 1.9b70 to run with the following procedure:

  1. Run the installation up to the error message telling you that there was a problem regarding the installer. Don't click it away!
  2. In
    C:\ProgramData\Cognitone\Setup\Synfire

    there's a newly created SETUP.EXE - set this file to Windows 7 compatibility and run it manually. This should bring up a UAC dialog and then install Synfire in

    C:\Program Files\Cognitone\Synfire
  3. After it has run properly, click the error box away. The content of
    C:\ProgramData\Cognitone\Setup

    gets deleted after that.

  4. Set
    C:\Program Files\Cognitone\Synfire\SYNFIRE.EXE

    to Windows 7 compatibility

After finishing this procedure, Synfire should run fine. At least for me it works as supposed.

andre's picture
andre
Offline
Last seen 14 hours 29 min ago

Thanks for the instructions. I wonder why it works on Windows 7 and 10, only not on 8.1. These startup issues are extremely difficult to debug on Windows. Even more so, as there are four programming languages and technologies involved.

BTW: There are new builds #71 online now.

sksherman's picture
sksherman
Offline
Last seen 4 months 2 weeks ago

Thank you all so much!  Off I go ...  :)

Steve

sksherman's picture
sksherman
Offline
Last seen 4 months 2 weeks ago

By the way, once I applied the above, the install started working not just for b31 but also for the newly downloaded b32.  So, I suspect there may have also been a change to the registry or some other file or configuration that "fixes" the issue.  That is, I did not need to do anything special to install b32.

Steve

HiEnergy's picture
HiEnergy
Offline
Last seen 2 weeks 1 hour ago

That compatibility flags setting gets stored in a database buried somewhere deep inside Windows.

So it's basically persistent and the fix should last now as every new installation will automatically be done in compatibility mode unless you revert the setting.

sksherman's picture
sksherman
Offline
Last seen 4 months 2 weeks ago

I believe that is correct, buried in the registry.

Attachments: 
spukipuki's picture
spukipuki
Offline
Last seen 3 weeks 3 days ago

Synfire (1.9 b71) crashes after switsching to another OSX app

When i switch OSX (10.13.06) focus to another app  (no matter what app) and click back on a Synfire window, the app freezes without recovering (coloured OSX ball rotating).

andre's picture
andre
Offline
Last seen 14 hours 29 min ago

This is the one bug I am desperately trying to reproduce but can't, although I'm on 10.13. too. Does it happen reliably every time? Do you have "Disable Widgets in Background" enabled?

spukipuki's picture
spukipuki
Offline
Last seen 3 weeks 3 days ago

You referring to the osx widgets? should i disable them completely via terminal?
(i don't know a way to disable them, just googled it)

Sorry for asking, didnt had the time to go through this thread completely.

So far it happens every time.

Update:
 i deactivated all widgets with this terminal code: defaults write com.apple.dashboard mcx-disabled -boolean YES
But it didnt help. Next time i opened Synfire, same same...

 

andre's picture
andre
Offline
Last seen 14 hours 29 min ago

So far it happens every time

Thanks. It makes me wonder why it doesn't happen here on same OS. Good to know. I'll double the effort to nail this down, as it's currently the only bug holding us back from declaring 1.9 an official release (there are other minor bugs, but this one is not tolerable for a release).

There's a checkbox in Synfire's Preferences to disable widgets in background. It's whether widgets should be grayed out when the window is not at front. It's off by default. You should probably re-enable your macOS widgets.

spukipuki's picture
spukipuki
Offline
Last seen 3 weeks 3 days ago

Today, i tried again. Same Error. I restarted my mac. No error. I can click outside Synfire as many times as i want.... (have my widgets still terminated)

spukipuki's picture
spukipuki
Offline
Last seen 3 weeks 3 days ago

External sync via MTC

Since i always have trouble getting Logic & Synfire into Rewire mode, i tried to sync the osx video player MTCVideoSlave via MTC.
When i hit play in Synfire the videplayer will  jump to the correct position in the video, but it seems it doesnt recieve a "play" command as well, just the position.

RobertoD's picture
RobertoD
Offline
Last seen 5 months 2 weeks ago

Where are the staves? ^____^

iMac Pro, Logic Pro, StudioOne 4, Synfire, Notion, NI Komplete, Heavyocity, various Spitfire/8Dio/VSL libs, Altiverb, a mate (Ines) and two cats (Oliva&Spritzi)

Ruchir's picture
Ruchir
Offline
Last seen 1 month 4 weeks ago

Is rewire actually working in 1.9? I'm using Studio One, and loading up the Synfire Transport for rewire doesn't do any sync'ing with Synfire's transport. Is there a dll for 1.9 that I should check for - where would it be located (it's not in my VST folder).

 

EDIT - resinstalled audio drivers and now working again.

Pages

Log in or register to post comments

Scholarly Lite is a free theme, contributed to the Drupal Community by More than Themes.